На языке Pascal составьте программу , которая запрашивает ввод случайных чисел a,b и N с
клавиатуры. Если оба числа больше N , то и программа должна напечатать слово "БОЛЬШЕ" , если меньше N , то должна напечатать "МЕНЬШЕ" , иначе должна напечатать "N в промежутке между a и b".Ответы на вопрос
a, b, N: integer;
begin
Readln(a);
Readln(b);
Readln(N);
if (a > N) and (b > N) then Writeln('БОЛЬШЕ')
else if (a < N) and (b < N) then Writeln('МЕНЬШЕ')
else Writeln('N в промежутке между a и b')
end.
Вот пример программы на языке Pascal, которая выполняет описанные вами условия:
```pascal program CompareNumbers;
var a, b, N: Integer;
begin // Запрашиваем ввод чисел a, b и N с клавиатуры Write('Введите число a: '); Readln(a); Write('Введите число b: '); Readln(b); Write('Введите число N: '); Readln(N); // Проверяем условие и выводим соответствующее сообщение if (a > N) and (b > N) then WriteLn('БОЛЬШЕ') else if (a < N) and (b < N) then WriteLn('МЕНЬШЕ') else WriteLn(N, ' в промежутке между ', a, ' и ', b); end. ```
Эта программа запрашивает у пользователя ввод трех чисел: `a`, `b` и `N`. Затем она проверяет условие: если оба числа `a` и `b` больше `N`, то программа выводит слово "БОЛЬШЕ". Если оба числа `a` и `b` меньше `N`, то программа выводит слово "МЕНЬШЕ". В противном случае программа выводит сообщение, что `N` находится в промежутке между `a` и `b`.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
