Написать программу в C++Дан одномерный массив x из n элементов. Найти порядковый номер первого по
счёту положительного элемента с чётным порядковым номером. Все отрицательные элементы после него переписать в массив y.Ответы на вопрос
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;
Вот пример программы на C++, которая решает задачу:
```cpp
#include
int main() { int n; cout << "Введите размер массива: "; cin >> n;
int x[n]; cout << "Введите элементы массива: "; for (int i = 0; i < n; i++) { cin >> x[i]; }
int firstPositiveIndex = -1; for (int i = 0; i < n; i += 2) { if (x[i] > 0) { firstPositiveIndex = i; break; } }
if (firstPositiveIndex == -1) { cout << "В массиве нет положительных элементов с четным порядковым номером." << endl; } else { int ySize = n - firstPositiveIndex - 1; int y[ySize]; for (int i = firstPositiveIndex + 1, j = 0; i < n; i++, j++) { y[j] = x[i]; }
cout << "Массив y: "; for (int i = 0; i < ySize; i++) { cout << y[i] << " "; } cout << endl; }
return 0; } ```
Программа запрашивает размер массива и элементы массива у пользователя. Затем она ищет первый положительный элемент с четным порядковым номером в массиве `x`. Если такой элемент найден, программа создает новый массив `y`, в который копирует все отрицательные элементы, следующие за найденным положительным элементом. Выводится массив `y`.
Примечание: В этой программе предполагается, что пользователь будет вводить только целочисленные значения для элементов массива. Если нужно обрабатывать вещественные числа, то следует изменить тип данных массивов `x` и `y` на `float` или `double`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
