Вопрос задан 15.02.2019 в 11:19. Предмет Информатика. Спрашивает Никулин Кирилл.

3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все

элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количе-ство замен. Протестировать программу на следующих исходных данных: а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4 НА ПАСКАЛЕ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кирбабин Сергей.
Var i,j,z,n,count:integer;
var a:array[1..1000] of integer;
begin
writeln('Введите Z: ');
readln(z);
writeln('Введите N: ');
readln(n);
writeln('Введите N чисел через пробел: ');
count:=0;
for i:=1 to n do begin
read(j);
if j<=z then a[i]:=j 
else begin a[i]:=z; count:=count+1; end;
end;
writeln('Количество замен: ',count);
write('Полученный массив: ');
for i:=1 to n do write(a[i], ' ');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

var N, Z, i, count: integer; arr: array of real;

begin write('Введите размер массива: '); readln(N); setLength(arr, N); write('Введите элементы массива: '); for i := 0 to N - 1 do begin read(arr[i]); end; write('Введите число Z: '); readln(Z); count := 0; for i := 0 to N - 1 do begin if arr[i] > Z then begin arr[i] := Z; count := count + 1; end; end; writeln('Полученный массив:'); for i := 0 to N - 1 do begin write(arr[i], ' '); end; writeln; writeln('Количество замен: ', count); end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос