Вопрос задан 28.04.2018 в 15:52.
Предмет Информатика.
Спрашивает Жунисбекова Нурила.
Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответы на вопрос
Отвечает Волк Анастасия.
Var
n: integer;
begin
readln(n);
if (n mod 10 = n div 10 mod 10) or (n mod 10 = n div 100) or (n div 10 mod 10 = n div 100) then
writeln('Есть')
else
writeln('Нет');
end.
Отвечает Волк Анастасия.
А еще есть такое вот "хитрое", но короткое решение:
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var s:=ReadInteger('n=').ToString.ToSortedSet;
if s.Count<3 then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
