
Вопрос задан 13.02.2019 в 10:37.
Предмет Информатика.
Спрашивает Долматова Мария.
Напишите программу Требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами
(номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. Входные данные Вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. Координаты - целые числа в интервале от 1 до 8. Выходные данные Требуется вывести слово YES, если ладья сможет побить фигуру за 1 ход и NO - в противном случае.

Ответы на вопрос

Отвечает Курбангелди Нурасыл.
//Dev-C++ 5.11 (C)
#include <stdio.h>
int main(void)
{int x,y,xl,yl;
scanf("%d%d%d%d",&xl,&yl,&x,&y);
if((xl==x)||(yl=y))
printf("YES");
else
printf("NO");
return 0;}
Пример ввода:
4 4 4 2
Пример вывода:
YES
#include <stdio.h>
int main(void)
{int x,y,xl,yl;
scanf("%d%d%d%d",&xl,&yl,&x,&y);
if((xl==x)||(yl=y))
printf("YES");
else
printf("NO");
return 0;}
Пример ввода:
4 4 4 2
Пример вывода:
YES


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili