Вопрос задан 11.02.2019 в 22:15.
Предмет Информатика.
Спрашивает Мохур Макс.
Решить в паскале №1 Составить программу вычисления значений функции F(x) на отрезке [a;b] с шагом
h. Результат представить в виде таблицы, первый столбец которой – значение аргумента, второй – соответствующие значения функции: F(x)=2cosx-1 №2 Дан числовой ряд и малая величина ε. Найти сумму ряда с точностью ε, общий член задан формулой: an=2n-1/2^nОтветы на вопрос
Отвечает Мельникова Дашуля.
1)var
a,b,h:real;
begin
readln(a);
readln(b);
readln(h);
while a<b do
begin
writeln(a,' ',2*cos(a)-1:8);
a+=h;
end
end.
2)var
eps,sum,current,n:real;
begin
readln(eps);
sum:=0;
n:=0;
repeat
current:=2*n-1/power(2,n);
n+=1;
sum+=current;
until current>eps;
writeln(sum);
end.
a,b,h:real;
begin
readln(a);
readln(b);
readln(h);
while a<b do
begin
writeln(a,' ',2*cos(a)-1:8);
a+=h;
end
end.
2)var
eps,sum,current,n:real;
begin
readln(eps);
sum:=0;
n:=0;
repeat
current:=2*n-1/power(2,n);
n+=1;
sum+=current;
until current>eps;
writeln(sum);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
