Вопрос задан 10.02.2019 в 14:42.
Предмет Информатика.
Спрашивает Кокунов Данила.
Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей.
Ввод незнакомого имени должен провоцировать заявление типа «Я С ВАМИ НЕЗНАКОМАОтветы на вопрос
Отвечает Ван-Ки-Сан Богдан.
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
var names:array[1..2,1..5] of string:=
(('Саша','Женя','Таня','Лена','Вася'),
('Александр','Евгений','Татьяна','Елена','Василий'));
var name:=ReadlnString('Введите краткое имя:');
var p:=0;
for var i:=1 to 5 do
if name=names[1,i] then begin p:=i; break end;
if p>0 then Writeln(names[2,p])
else Writeln('Я вас не знаю!')
end.
Тестовое решение
Введите краткое имя: Лена
Елена
begin
var names:array[1..2,1..5] of string:=
(('Саша','Женя','Таня','Лена','Вася'),
('Александр','Евгений','Татьяна','Елена','Василий'));
var name:=ReadlnString('Введите краткое имя:');
var p:=0;
for var i:=1 to 5 do
if name=names[1,i] then begin p:=i; break end;
if p>0 then Writeln(names[2,p])
else Writeln('Я вас не знаю!')
end.
Тестовое решение
Введите краткое имя: Лена
Елена
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
