
составить программу на ЯП Паскаль, которая бы при помощи генератора СЧ [напомню, это ф-ции
randomize и random(i)] позволяла бы сыграть с ПК в игру «угадай число» при помощи виртуальной игральной кости. Счёт ведётся до 10 набранных очков. Если угадал – плюс одно очко, не угадал – счёт не меняется. Счет вести и для игрока и для ПК.

Ответы на вопрос

program game;
var
costi, me, comp, myscore, compscore, round: integer;
begin
randomize;
costi := random(6);
myscore := 0;
compscore := 0;
for round := 1 to 10 do
begin
writeln('Введите ваще число от 1 до 6');
readln(me);
if me = costi then
writeln('Выпало число ', costi, '. Вы угадали, счет становится (', myscore + 1, ';', compscore,')')
else writeln('Выпало число ', costi, '. Вы не угадали, счет остается преждним (', myscore, ';', compscore,')');
if me = costi then myscore := myscore + 1;
writeln('Кости бросает компьютер');
costi := random(6);
comp := random(6);
if comp = costi then
writeln('Выпало число ', costi, '. Компьютер угадал, счет становится (', myscore, ';', compscore + 1,')')
else writeln('Выпало число ', costi, '. Компьютер не угадал, счет остается преждним (', myscore, ';', compscore,')');
if comp = costi then compscore := compscore + 1;
end;
if myscore>compscore then writeln ('Вы победили!');
if myscore<compscore then writeln ('Вы проиграли.');
if myscore=compscore then writeln ('Боевая ничья!');
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili