Вопрос задан 27.04.2018 в 14:31.
Предмет Информатика.
Спрашивает Гарбуз Ксения.
ПОМОГИИИИИИТЕЕЕЕЕ Ниже записана программа. Получив на вход число , эта программа печатает два
числа, L и M .Укажите наибольшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом 0. var x, L, M: integer; begin readln(x); L:=0; M:=0; while x > 0 do begin L:= L + 1; if x mod 2 = 0 then M:= M + x mod 10; x:= x div 10; end; writeln(L); write(M); endОтветы на вопрос
Отвечает Утюльбаева Нурай.
Оператор div отрезает последнюю цифру числа, а mod считает остаток от деления на 2. Если он равен нулю, то выполняется действие M:= M + x mod 10.
Сначала выводится переменная L, в ней содержится счетчик, который считает, сколько раз оператор div отрежет цифру. Отсюда следует, что число должно быть трехзначным. В нашем случае ответом будет число 999, потому что div отрежет последнюю цифру три раза, а условие if x mod 2 = 0 then не будет выполнятся, потому что остаток от деления на 2 числа 999 не равен нулю, программа выведет 0.
Ответ: 999
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 34
Информатика 35
Информатика 14
Информатика 35
Информатика 201
Информатика 65
Информатика 109
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
