Вопрос задан 06.02.2019 в 22:19.
Предмет Информатика.
Спрашивает Волков Андрей.
Написать программу Паскаль -перенести первое число в конец Число трехзначное Помогите:)
Ответы на вопрос
Отвечает Сугоняева Василиса.
Прошу:)
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
b := d mod 100 div 10;
c := d mod 10;
writeln(b, c, a);
end.
можно ещё сократить:
var a, b, c, d: integer;
begin
readln(d);
writeln(d mod 100 div 10, d mod 10, d div 100);
end.
или даже:
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
writeln(d - a * 100, a);
end.
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
b := d mod 100 div 10;
c := d mod 10;
writeln(b, c, a);
end.
можно ещё сократить:
var a, b, c, d: integer;
begin
readln(d);
writeln(d mod 100 div 10, d mod 10, d div 100);
end.
или даже:
var a, b, c, d: integer;
begin
readln(d);
a := d div 100;
writeln(d - a * 100, a);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
