Вопрос задан 06.02.2019 в 12:38.
Предмет Информатика.
Спрашивает Собинин Данила.
Построить блок-схему алгоритма и написать программу для решения следующей задачи. даны
действительные числа x и y. Если x и y отрицательны, то уаждое значение заменить его модулем; если отрицательно только одно из них, то оба значения увеличить на 0.5, в противном случае извлечь из каждого квадратный корень.Ответы на вопрос
Отвечает Пересыпкин Вова.
var
x, y:real;
begin
readln(x, y);
if (x>0) and (y>0) then
begin
x:=sqrt(x);
y:=sqrt(y);
writeln(x,' ', y);
end;
if (x<0) and (y<0) then
begin
x:=x*(-1);
y:=y*(-1);
writeln(x,' ', y);
end;
if (x<0) or (y<0) then
begin
x:=x+0.5;
y:=y+0.5;
writeln(x,' ', y);
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
