Вопрос задан 06.02.2019 в 02:30.
Предмет Информатика.
Спрашивает Едилбай Бимен.
Помогите, пожалуйста, с паскалем! Входные данные Вводятся 2 числа: x и d. Выходные данные
Подсчитайте и выведите одно число - сколько раз встречается в записи натурального числа x цифра d. Примеры входные данные 123 2 выходные данные 1 входные данные 141 1 выходные данные 2Ответы на вопрос
Отвечает Любимова Елена.
Var
x,d,count:integer;
begin
write('x=');
readln(x);
write('d=');
readln(d);
while x>0 do
begin
if x mod 10 = d then
count:=count+1;
x:= x div 10;
end;
writeln(count);
end.
x,d,count:integer;
begin
write('x=');
readln(x);
write('d=');
readln(d);
while x>0 do
begin
if x mod 10 = d then
count:=count+1;
x:= x div 10;
end;
writeln(count);
end.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
