Вопрос задан 06.02.2019 в 01:38.
Предмет Информатика.
Спрашивает Стрельников Степан.
. Составить программу для нахождения и печати всех Пифагоровых чисел, не превышающих 20.
Ответы на вопрос
Отвечает Мыхалчыч Витя.
Пифагоровыми числами называются числа, для которых выполняется равенство a²+b²= c².
//Pascal
var
i, j, k: integer;
begin
for i := 1 to 20 do
for j := i to 20 do
for k := j to 20 do if i * i + j * j = k * k then writeln(i:4, j:4, k:4);
end.
//Pascal
var
i, j, k: integer;
begin
for i := 1 to 20 do
for j := i to 20 do
for k := j to 20 do if i * i + j * j = k * k then writeln(i:4, j:4, k:4);
end.
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
