Вопрос задан 05.02.2019 в 08:06.
Предмет Информатика.
Спрашивает Радыш Владимир.
Составить программу в паскаль. Вычислить и запомнить значения функции Yi=X , если Xi<0 Yi=0 ,
если Xi=0 -1 , если Xi≤0 где Xi - элементы массива из 20 элементовОтветы на вопрос
Отвечает Егоян Белла.
# include <bits\stdc++.h>
using namespace std;
int main()
{
int x[20], y[20];
int i, n;
cin >> n;
for(i = 1; i <= n; ++i)
cin >> x[i] >> y[i];
if(x[i] > 0)
y[i] = x[i];
if(y[i] == 0)
x[i] = 0;
if(x[i] <= 0)
puts('-1');
else
cout << x[i] << ' ' << y[i];
return 0;
}
using namespace std;
int main()
{
int x[20], y[20];
int i, n;
cin >> n;
for(i = 1; i <= n; ++i)
cin >> x[i] >> y[i];
if(x[i] > 0)
y[i] = x[i];
if(y[i] == 0)
x[i] = 0;
if(x[i] <= 0)
puts('-1');
else
cout << x[i] << ' ' << y[i];
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
