Вопрос задан 04.02.2019 в 12:25.
Предмет Информатика.
Спрашивает Зайкин Дмитрий.
Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного
числа. (ABC Pascal)Ответы на вопрос
Отвечает Малышева Злата.
Var
a,chislo,t:longint;
c,nov,posl:integer;
begin
readln(a);
posl:=a mod 10;
chislo:=a;
t:=1;
repeat
a:=a div 10;
t:=t*10;
until a<10;
chislo:=chislo mod t;
chislo:=posl*t+chislo-posl+a;
writeln(chislo);
readln;
end.
a,chislo,t:longint;
c,nov,posl:integer;
begin
readln(a);
posl:=a mod 10;
chislo:=a;
t:=1;
repeat
a:=a div 10;
t:=t*10;
until a<10;
chislo:=chislo mod t;
chislo:=posl*t+chislo-posl+a;
writeln(chislo);
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
