Вопрос задан 03.02.2019 в 11:02.
Предмет Информатика.
Спрашивает Кудрявцев Андрей.
ПАСКАЛЬПо условиям чемпионата 2003 года из премьер-лиги выбывают две последние в турнирной таблице
команды. Составьте программу, определяющую обе команды, выбывающие из премьер-лиги.Ответы на вопрос
Отвечает Палкина Анжелика.
Можно с помощью массива
program m1;
var a: array[1..10] of integer;
i,n,k,h,v,c: integer;
begin
readln (n);
for i:= 1 to n do readln(a[i]);
k:= a[1];
v:= 1;
for i:= 2 to n do begin if a[i]<k then k:= a[i]; v:= i;
end;
h:= a[2];
c:= 2;
for i:= 3 to n do begin if a[i]<h then h:= a[i]; c:= i;
end;
writeln (v,c); {где "v" и "c" номера выбывших команд}
end.
program m1;
var a: array[1..10] of integer;
i,n,k,h,v,c: integer;
begin
readln (n);
for i:= 1 to n do readln(a[i]);
k:= a[1];
v:= 1;
for i:= 2 to n do begin if a[i]<k then k:= a[i]; v:= i;
end;
h:= a[2];
c:= 2;
for i:= 3 to n do begin if a[i]<h then h:= a[i]; c:= i;
end;
writeln (v,c); {где "v" и "c" номера выбывших команд}
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
