Вопрос задан 02.02.2019 в 06:37.
Предмет Информатика.
Спрашивает Жалковский Родион.
ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ Язык Free Pascal GNU C GNU C++ Delphi Java Python 2.7 Mono C# Python 3.1 Min
время, сек 0.001 0.004 0.002 0.002 0.124 0.008 0.064 0.046 Среднее время, сек 0.005 0.006 0.011 0.005 0.124 0.024 0.064 0.079 Верных решений 73 5 102 9 1 2 1 301 Дано целое число, не меньшее 2. Выведите его наименьший натуральный делитель, отличный от 1. Входные данные Вводится целое положительное число. Выходные данные Выведите ответ на задачу. Примеры входные данные 15 выходные данные 3Ответы на вопрос
Отвечает Поталай Ника.
Паскаль:
Program P;
uses crt;
var n,i:integer;
Begin clrscr;
write(' N='); readln(n);
i:=1;
while i<=n do begin i:=i+1;
if n mod i=0 then
begin
writeln('Наименьший делитель=',i);
end;
end;
end.
Program P;
uses crt;
var n,i:integer;
Begin clrscr;
write(' N='); readln(n);
i:=1;
while i<=n do begin i:=i+1;
if n mod i=0 then
begin
writeln('Наименьший делитель=',i);
end;
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 23
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
