
Вопрос задан 01.02.2019 в 19:54.
Предмет Информатика.
Спрашивает Макаревич Галя.
Помогите пожалуйста решить!)Составить программу, которая печатает true, если точка с координатами
(х, у) принадлежит заштрихованной области, и false в противном случае:


Ответы на вопрос

Отвечает Сергеева Лена.
По рисунку 1:
var
x, y: real;
begin
Write('Введите через пробел координаты точки x,y: ');
Readln(x, y);
Writeln((y <= abs(x - 4)) and (y <= 4))
end.
Тестовое решение:
Введите через пробел координаты точки x,y: 3.15 -0.72
True
Введите через пробел координаты точки x,y: 3 3
False
По рисунку 2:
var
x, y: real;
p,q:boolean; {только для сокращения операторов}
begin
Write('Введите через пробел координаты точки x,y: ');
Readln(x, y);
p:=(sqr(x)+sqr(y)<=25);
q:=(sqr(x)+sqr(y)>=9);
Writeln((x>=0.5) and p and q)
end.
Тестовое решение:
Введите через пробел координаты точки x,y: 4 2.5
True
Введите через пробел координаты точки x,y: 3.7 -4.3
False
Введите через пробел координаты точки x,y: 2 -3
True
var
x, y: real;
begin
Write('Введите через пробел координаты точки x,y: ');
Readln(x, y);
Writeln((y <= abs(x - 4)) and (y <= 4))
end.
Тестовое решение:
Введите через пробел координаты точки x,y: 3.15 -0.72
True
Введите через пробел координаты точки x,y: 3 3
False
По рисунку 2:
var
x, y: real;
p,q:boolean; {только для сокращения операторов}
begin
Write('Введите через пробел координаты точки x,y: ');
Readln(x, y);
p:=(sqr(x)+sqr(y)<=25);
q:=(sqr(x)+sqr(y)>=9);
Writeln((x>=0.5) and p and q)
end.
Тестовое решение:
Введите через пробел координаты точки x,y: 4 2.5
True
Введите через пробел координаты точки x,y: 3.7 -4.3
False
Введите через пробел координаты точки x,y: 2 -3
True


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili