Вопрос задан 31.01.2019 в 10:51.
Предмет Информатика.
Спрашивает Кудряшов Михаил.
Написать программу в формате "Паскаль", которая генерируется случайное трехзначное число и
подсчитает количество цифр в нем равных 4 и 5. Очень срочно! Помогите, пожалуйста!Ответы на вопрос
Отвечает Тыщенко Ксения.
// PascalABC.NET 3.2, сборка 1387 от 17.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
randomize;
var s:=Random(100,999).ToString;
Writeln('Исходное число ',s);
var k4:=0;
var k5:=0;
for var i:=1 to s.Length do
case s[i] of
'4':k4+=1;
'5':k5+=1
end;
Writeln('Четверок в числе- ',k4,', пятерок- ',k5)
end.
Пример
Исходное число 954
Четверок в числе- 1, пятерок- 1
// Внимание! Если программа не работает, обновите версию!
begin
randomize;
var s:=Random(100,999).ToString;
Writeln('Исходное число ',s);
var k4:=0;
var k5:=0;
for var i:=1 to s.Length do
case s[i] of
'4':k4+=1;
'5':k5+=1
end;
Writeln('Четверок в числе- ',k4,', пятерок- ',k5)
end.
Пример
Исходное число 954
Четверок в числе- 1, пятерок- 1
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
