Вопрос задан 24.04.2018 в 19:49.
Предмет Информатика.
Спрашивает Смоляр Женя.
Напишите программу по последовательному вводу пяти различных чисел чисел. Причём программа не
должна разрешать ввод одинаковых чисел.Ответы на вопрос
Отвечает Лебедева Анастасия.
Вот листинг:
"if freedom is outlawed, only outlaws will have freedom." © TSRh

Отвечает Стан Ваня.
Const
N = 5;
Var
P:array[1..N] of integer;
C,i,j,B:integer;
Begin
WriteLn('Введите пять целых чисел');
For i:=1 to N do
Begin
Repeat
B:=0;
Read(C);
For j:= 1 to i-1 do
if P[j] = C then B:=j;
if B > 0 then WriteLn('Число ',P[B],' уже было'#13'Попробуйте ещё раз')
else P[i]:=C;
Until B = 0;
End;
WriteLn('Полученная последовательность');
For i:= 1 to N do Write(P[i],' ')
End.
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 2231
Информатика 86
Информатика 50
Информатика 234
Информатика 31
Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
