Вопрос задан 26.01.2019 в 08:12. Предмет Информатика. Спрашивает Попова Маргарита.

Дано целое трехзначное число x составьте программу вычисления суммы и произведения цифр

трехзначного числа x значения x ввести с клавиатуры
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Паршукова Элла.
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=abs(ReadInteger).Tostring.Select(x->x.ToDigit);
writeln('сумма цифр: ',a.Sum);
write('произведение цифр: ',a.Aggregate(Real(1),(x,y)->x*y));
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос