Вопрос задан 25.01.2019 в 07:06.
Предмет Информатика.
Спрашивает Шиян Макс.
Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников
прямоугольный. Если они прямоугольные, то должно выводится сообщение 'Это прямоугольный треугольник'.Ответы на вопрос
Отвечает Басидаш Елизавета.
Var a,b,c:real;
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(b))))then
write('Это прямоугольный треугольник')
else
write('Это не прямоугольный треугольник')
end.
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(b))))then
write('Это прямоугольный треугольник')
else
write('Это не прямоугольный треугольник')
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
