Вопрос задан 24.04.2018 в 07:55.
Предмет Информатика.
Спрашивает Веретина Саша.
(Паскаль) Дан текстовый файл, содержащий вещественные числа (положительные и отрицательные) в
произвольном порядке. Сформируйте массив, содержащий только положительные числа из файла, и найдите наименьшее среди них.Ответы на вопрос
Отвечает Мамаев Максим.
Program filework;
var f:text;
i, n, count:integer;
l:string;
arr:array of real;
answ:real;
begin
assign(f, 'C:\Users\HO4HOU_TTaPKuPucT\Desktop\test_file.txt'); // В кавычках путь к файлу
reset(f);
while not eof(f) do begin
readln(f, l);
if StrToFloat(l) > 0 then
Inc(count);
end;
SetLength(arr, count);
reset(f);
i:=0;
while not eof(f) do begin
readln(f, l);
if StrToFloat(l) > 0 then begin
arr[i]:=StrToFloat(l);
Inc(i);
end;
end;
answ:=arr[0];
for i:=1 to arr.Length - 1 do
if arr[i] < answ then answ:=arr[i];
writeln(answ);
close(f);
end.
P.S. Программа работает с неограниченным числом положительных чисел в файле
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 21
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
