Вопрос задан 02.04.2018 в 22:44.
Предмет Информатика.
Спрашивает Романова Софья.
Составьте программу, выводящую на экран числа от 1 до 10, а также их квадраты и кубы следующим
образом: 1 1 1 2 4 8 3 9 27 ---------------- 10 100 1000Ответы на вопрос
Отвечает Болатова Раушангүл.
Зависит от того, в чем работаете(Паскаль, С). Как самый просто вариант в паскале("в лоб"):
uses crt
var i:integer;
begin
i:=1; {присваиваем 1}
repeat
writeln(); {пустая строка}
write(i); {пишем само число i}
write(' '); {ставим пробел}
write(exp(2*ln(i)):2:0); {считаем квадрат числа i}
write(' '); {пробел}
write(exp(3*ln(i)):2:0); {считаем куб числа i}
i:=i+1; {новое значение i}
until i>10; {условие окончания i>10}
readkey; {закрытие по нажатию программы}
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
