Вопрос задан 19.01.2019 в 23:30.
Предмет Информатика.
Спрашивает Шаронина Лиза.
Написать программу для паскаля. Дана квадратная матрица порядка n(n=5). Если в данной матрице a нет
отрицательных элементов, то транспонировать её, иначе выдать сообщение.Ответы на вопрос
Отвечает Лукьянчик Полина.
Uses crt;
const N=2;
var a:array [1..N,1..N] of real;
i,j,k:integer;
begin
k:=0; writeln('Введите матрицу:');
for i:=1 to N do
for j:=1 to N do
begin
read(a[i,j]);
if a[i,j]<0 then inc(k);
end;
if k>0 then writeln('В матрице отрицательный элемент')
else
for i:=1 to N do
begin
for j:=1 to N do
write(a[j,i]:3:0);
writeln;
end;
end.
const N=2;
var a:array [1..N,1..N] of real;
i,j,k:integer;
begin
k:=0; writeln('Введите матрицу:');
for i:=1 to N do
for j:=1 to N do
begin
read(a[i,j]);
if a[i,j]<0 then inc(k);
end;
if k>0 then writeln('В матрице отрицательный элемент')
else
for i:=1 to N do
begin
for j:=1 to N do
write(a[j,i]:3:0);
writeln;
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
