Составить программу Дан массив натуральных чисел , размерность -12!) Заполнение массива производить
с клавиатуры 2) Вывести на печать только элементы кратные 2 3)Найти сумму первых пяти элементов Составить программу Дан массив целых чисел , размерность -12 1) Заполнение массива производить случайными числами из диапозона [-10;35]2)Вывести на печать только положительные элементы 3)Найти количество отрицательных элементов Составить программу Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .Ответы на вопрос
Задача #1
var a:array[1..12] of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 12 do
read(a[i]);
for i:=1 to 12 do
if a[i] mod 2 = 0 then write(a[i],' ');
for i:=1 to 5 do
s:=s+a[i];
writeln(s);
end.
Задача #2.
var a:array[1..12] of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 12 do begin
randomize;
a[i]:=random(46)-10 {функция рандом будет вызывать значения от 0 до 45, и еще -10 получится от -10 до 35}
end;
For i:=1 to 12 do begin
if a[i]>0 then write(a[i],' ');
if a[i]<0 then s:=s+1;
end;
writeln(s);
end.
Стоит учесть что он не будет учитывать 0. Например, он может выдать вам 5 положительных(напишет) и количество отрицательных - 2, И это означает что остальные 5 в массиве нули.
Задача #3
var a:integer;
begin
read(a);
write(a*30);
end.
1 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
write('Write a[ ',i,' ] = ');
readln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i] mod 2=0 then writeln(a[i]);
end;
for i:=1 to 5 do
begin
sum:=a[i]+sum;
end;
write('SUMA = ');
writeln(sum);
readln;
end.
2 программа
uses crt;
var
a: array [0 .. 12] of integer;
sum, i:integer;
begin
sum:=0;
for i:=1 to 12 do
begin
a[i]:= random(46)-10; // random(max-min+1)+min;
end;
for i:=1 to 12 do
begin
if (a[i]>0) then writeln(a[i]);
end;
for i:=1 to 12 do
begin
if a[i]<0 then inc(sum);
end;
write('OTRIC ELEMENTOV = ');
writeln(sum);
readln;
end.
ткань ...
uses crt;
var
days,m:integer;
begin
days:= 30; //дней в месяце
m:=135; //метров сделали за день
writeln('За месяц = ',days*m, ' метров ');
readln;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
