Вопрос задан 19.01.2019 в 14:36. Предмет Информатика. Спрашивает Даниленко Олександра.

Помогите написать программу перевода числа из двоичной системы в десятичную с использованием

функции возведения в степень. Я написала, но у меня где-то ошибка.b:=0; m:=length(max)-1;j:=m;for i:=1 to m do begin val(max[i],p,code); while j>=0 do p:=p*step(2,j); b:=b+p; j:=j-1; writeln(b); end;Поясняю, что тут и как. Эта мини-задача, входящая в решение одной масштабной задачищи. Дана строка max, в которой записано двоичное число. Функция step(x,y:integer):integer возводит число x в степень y. Помогите найти и исправить ошибку, только, пожалуйста, не надо писать СОВЕРШЕННО ДРУГОЙ способ решения. Заранее благодарю))
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Суйесин Саян.
Begin
 
  max := '1010';
  b := 0;
  m := length(max);
  j := m - 1;
 
  for i := 1 to m do
 
  begin
   
    val(max[i], p, code);
   
    {while j >= 0 do}
   
    p := p * step(2, j);
   
    b := b + p;
    j := j - 1;
   
    writeln(b);
   
  end;
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос