Вопрос задан 19.01.2019 в 13:33.
Предмет Информатика.
Спрашивает Жильцова Алина.
Помогите написать программу на паскале :) Составить программу, проверяющую, являются ли данные три
числа взаимно простыми. Использовать подпрограмму.Ответы на вопрос
Отвечает Артюшенко Аленка.
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
a, b, c: integer;
{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
while b > 0 do
begin
t := b;
b := a mod b;
a := t;
end;
gcd := a;
end;
{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
isCoprime := gcd(gcd(a, b), c) = 1;
end;
begin
read(a, b, c);
if isCoprime(a, b, c) then write('Числа взаимно простые')
else write('Числа не являются взаимно простыми');
end.
var
a, b, c: integer;
{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
while b > 0 do
begin
t := b;
b := a mod b;
a := t;
end;
gcd := a;
end;
{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
isCoprime := gcd(gcd(a, b), c) = 1;
end;
begin
read(a, b, c);
if isCoprime(a, b, c) then write('Числа взаимно простые')
else write('Числа не являются взаимно простыми');
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
