Вопрос задан 19.01.2019 в 07:41. Предмет Информатика. Спрашивает Егорова Оксана.

Напишите программу, которая считывает из файла строки - каждую строку в отдельную строковую

переменную, затем печатает их и их количество. Язык С++
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кошелев Егор.
Проверял на C++11 - работает

#include <fstream>
#include <iostream>
#include <vector>
#include <string>

using namespace std;

#define FILENAME "input.txt"

int main() {
    ifstream fin(FILENAME);
    vector <string> lines;
    string s;
    while (getline(fin, s))
        lines.push_back(s);
    cout << "Lines:\n";
    for (int i = 0; i < lines.size(); i++)
        cout << lines[i] << endl;   
    cout << "Count of lines: " << lines.size() << endl;
    return 0;
}
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос