Вопрос задан 19.01.2019 в 05:41.
Предмет Информатика.
Спрашивает Алискеров Рамазан.
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных,
количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.Ответы на вопрос
Отвечает Вишневская Алина.
var
n,o,p,k,i:integer;
a:real;
begin
repeat
write ('N = ');readln(n);
until (n>0);
i:=0;
k:=0;
p:=0;
o:=0;
repeat
write ('Ввод: ');readln(a);
i:=i+1;
if a<0 then o:=o+1 else
if a>0 then p:=p+1 else k:=k+1;
until i=n;
writeln ('Кол-во положительных: ',p);
writeln ('Кол-во отрицательных: ',o);
writeln ('Кол-во нулей: ',k);
readln;
end.
Отвечает Прус Виталий.
program aa;
var minus, plus, zero, N, C, Q : integer;
begin
zero:=0;
plus:=0;
minus:=0;
C:=0;
writeln('Введите количество чисел);
read(N);
writeln('Вводите числа');
while C<N do begin
read(Q);
C:=C+1;
If Q=0 then zero:=zero+1;
If Q<0 then minus:=minus+1;
If Q>0 then plus:=plus+1;
end;
writeln('Нулей: ',zero);
writeln('Отрицательных: ',minus);
writeln('Положительных: ',plus);
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
