
Вопрос задан 18.01.2019 в 12:36.
Предмет Информатика.
Спрашивает Тареева Виктория.
Составить программу на паскале 18. Заполнить массив случайным образом и вывести на экран только
элементы кратные 3 и 5.

Ответы на вопрос

Отвечает Дідушок Даша.
Сколько элементов в массиве? Меньше какого числа должны быть элементы массива? Вроде так



Отвечает Панцыр Юлька.
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018
//Внимание! Если программа не работает, обновите версию!
begin
var mas:=ArrRandom(20,-99,99);
var t:=mas.Where(t->(t mod 3 = 0) and (t mod 5 =0)); t.println;
end.
Как в школе учат ->
var mas:Array [1..20] of integer; i:integer;
begin
randomize;
for i:=1 to 20 do
mas[i]:=random(-99,99);
for i:=1 to 20 do
if (mas[i] mod 3 = 0) and (mas[i] mod 5 =0) then
Write(mas[i]:4);
end.
//Внимание! Если программа не работает, обновите версию!
begin
var mas:=ArrRandom(20,-99,99);
var t:=mas.Where(t->(t mod 3 = 0) and (t mod 5 =0)); t.println;
end.
Как в школе учат ->
var mas:Array [1..20] of integer; i:integer;
begin
randomize;
for i:=1 to 20 do
mas[i]:=random(-99,99);
for i:=1 to 20 do
if (mas[i] mod 3 = 0) and (mas[i] mod 5 =0) then
Write(mas[i]:4);
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili