Вопрос задан 23.04.2018 в 04:47. Предмет Информатика. Спрашивает Калила Айко.

Составьте программу, которая позволяет заменить в строке слово мама на слово папа

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнов Артём.

Var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s);  // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
 begin  
Delete(s, i, 4);  // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа 
Insert('папа', s, i);  // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос