Вопрос задан 16.01.2019 в 15:02.
Предмет Информатика.
Спрашивает Шокина Софья.
Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет
сумму элементов массива, кратных трем и заканчивающихся на 7( программа Pascal)Ответы на вопрос
Отвечает Эльмовский Дмитрий.
Var a:array[1..5] of integer;
i,s:integer;
begin
writeln('Введите 5 чисел:');
for i:=1 to 5 do
begin
read(a[i]);
if (a[i] mod 3 = 0)and(a[i] mod 10 = 7) then s:=s+a[i];
end;
writeln('s = ',s);
end.
Пример:
Введите 5 чисел:
125 273 117 471 207
s = 324
i,s:integer;
begin
writeln('Введите 5 чисел:');
for i:=1 to 5 do
begin
read(a[i]);
if (a[i] mod 3 = 0)and(a[i] mod 10 = 7) then s:=s+a[i];
end;
writeln('s = ',s);
end.
Пример:
Введите 5 чисел:
125 273 117 471 207
s = 324
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
