Вопрос задан 16.01.2019 в 09:00. Предмет Информатика. Спрашивает Панасенко Анатолий.

Составьте программу для вычисления гипотенузы, периметра и площади прямоугольного треугольника,

если известны его катеты.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Борозна Павел.

с - гипотенуза, а и b - катеты, тогда по теореме Пифагора: с² = а² + b², откуда с = √(а² + b²).

Р = а + b + c, S = 1/2 · ab.

program praym_treug;

var a,b,c,s,p:real;

begin

write('Введите катеты: '); readln(a,b);

c:=sqrt(a*a+b*b);

p:=a+b+c;

s:=1/2*a*b;

write('Гипотенуза = ',c:5:2,' Периметр = ',p:5:2,' Площадь = ',s:5:2);

end.

:5:2 - форматный вывод, т.е. ограничение на количество цифр в ответе. Для чисел типа real это важно, т.к. обычно в ответе после запятой много цифр (в случае форматного вывода  останется только 2 - в нашем случае)


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос