Вопрос задан 15.01.2019 в 18:10.
Предмет Информатика.
Спрашивает Филипцева Алёночка.
Срочноо, помогите!! Напишите программу В ПАСКАЛЕ вычисления выражения: s=x^3+x^5+x^n, где x и n
вводятся с клавиатуры. Используйте функцию вычисления степени.Ответы на вопрос
Отвечает Тугайлаев Хаджимурад.
Var
X,N:real;
Begin
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+power(x,n));
End.
С помощью функции возведения в степень, при условии, что основание - число вещественное, а показатель - целое.
Function St(O:real;P:integer):real;
Begin
result:=1;
For P:= 1 to P do
result:=result*P;
End;
Var
X:real;
n:integer;
Begin
Write('x = ');
ReadLn(x);
Write('n = ');
ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+St(x,n));
End.
X,N:real;
Begin
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+power(x,n));
End.
С помощью функции возведения в степень, при условии, что основание - число вещественное, а показатель - целое.
Function St(O:real;P:integer):real;
Begin
result:=1;
For P:= 1 to P do
result:=result*P;
End;
Var
X:real;
n:integer;
Begin
Write('x = ');
ReadLn(x);
Write('n = ');
ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+St(x,n));
End.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
