Вопрос задан 15.01.2019 в 14:43. Предмет Информатика. Спрашивает Тузлукова Анастасия.

Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения

значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым способом
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Леонтьева Милена.
// PascalABC.NET 3.0, сборка 1111
begin
  var a:=ArrRandom(10,-15,25);
  Write('Исходный массив: '); a.Println(',');
  Writeln('Сумма min+max=',a.Min+a.Max)
end.

Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
0 0
Отвечает Редько Валерия.
Program Project1;
var i, max, min:integer; mass:array [0..9] of integer;
begin
  randomize;
  for i:=1 to 9 do mass[i]:=Random(100);
  max:=0;
  min:=100;

  for i:=1 to 9 do begin
    if max<mass[i] then max:=mass[i];
    if min>mass[i] then min:=mass[i];
  end;

  writeln('max: ', max);
  writeln('min: ', min);
  writeln('max + min = ', max+min);
end.


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос