Вопрос задан 13.01.2019 в 13:18.
Предмет Информатика.
Спрашивает Голота Валера.
Написать программу (Процедуру), выводящую квадраты чисел от a до b (a,b вводятся с клавиатуры);
Ответы на вопрос
Отвечает Иванов Анатолий.
И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
