
Вопрос задан 12.01.2019 в 00:17.
Предмет Информатика.
Спрашивает Маноскина Лера.
Помогите написать программу в Паскале ..... Дано трехзначное число х найти сумму его цифр, среднее
арифметическое и записать число в обратном порядке.

Ответы на вопрос

Отвечает Кузьмина Оксана.
Var
m,n,n1,n2,n3,n4:integer;
begin
Write('Введите трехзначное натуральное число: ');
Readln(n);
n1:= n mod 10;
n2:= (n mod 100) div 10;
n3:= n div 100;
m:=n1+n2+n3;
Write('сумма цифр: ',m);
Write('среднее арифметическое: ',m/3);
m = 100*n1 + 10*n2 + n3;
Writeln(' в обратном порядке: ',m)
end.
m,n,n1,n2,n3,n4:integer;
begin
Write('Введите трехзначное натуральное число: ');
Readln(n);
n1:= n mod 10;
n2:= (n mod 100) div 10;
n3:= n div 100;
m:=n1+n2+n3;
Write('сумма цифр: ',m);
Write('среднее арифметическое: ',m/3);
m = 100*n1 + 10*n2 + n3;
Writeln(' в обратном порядке: ',m)
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili