 
Вопрос задан 08.01.2019 в 11:27.
Предмет Информатика.
Спрашивает Быков Виктор.
Дан массив из 10 элементов. Составить программу которая даёт ответ на вопрос есть ли в массиве
более одного элемента равного максимальному. Ответ выводится в виде Да/Нет. PASCAL. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Курилова Ксения.
                
    // PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,1,9); a.Println;
if a.Where(t->t=a.Max).Count>1 then
Writeln('Есть элементы, равные максимальному')
else
Writeln('Нет элементов, равных максимальному')
end.
Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному
1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
                                        // Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,1,9); a.Println;
if a.Where(t->t=a.Max).Count>1 then
Writeln('Есть элементы, равные максимальному')
else
Writeln('Нет элементов, равных максимальному')
end.
Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному
1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			