Вопрос задан 08.01.2019 в 08:19.
Предмет Информатика.
Спрашивает Аников Денис.
Нужно составить программу в paskal ABC: Массив содержит n случайных двузначных чисел. Определить
сколько в данном массиве четных чисел. Вывести все его элементы с нечетными номерами.Ответы на вопрос
Отвечает Сорокина Дарья.
Const n=10;
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(90)+10;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2=0 then k:=k+1;
writeln('Четных чисел: ',k);
writeln('Элементы с нечетными номерами:');
for i:=1 to n do
if i mod 2=1 then write(a[i]:4);
writeln;
end.
Пример:
Массив A:
13 77 63 94 75 87 22 56 59 42
Четных чисел: 4
Элементы с нечетными номерами:
13 63 75 22 59
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(90)+10;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2=0 then k:=k+1;
writeln('Четных чисел: ',k);
writeln('Элементы с нечетными номерами:');
for i:=1 to n do
if i mod 2=1 then write(a[i]:4);
writeln;
end.
Пример:
Массив A:
13 77 63 94 75 87 22 56 59 42
Четных чисел: 4
Элементы с нечетными номерами:
13 63 75 22 59
Отвечает Новиков Кирилл.
Var a: array [1..10] of integer;var kolvo:integer;beginfor var i:= 1 to 10 do a[i]:= random(89)+10;for var c:= 1 to 10 do begin if(a[c] mod 2 = 0) then kolvo:=kolvo+1; end;writeln('Четных чисел: ', kolvo);for var i:= 1 to 10 do write(a[i]:4);end.объяснение нужно?
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
