Вопрос задан 05.01.2019 в 07:09.
Предмет Информатика.
Спрашивает Коренев Ваня.
Составьте программу нахождения наименьшего общего кратного (НОК) двух чисел, используя формулу: А*В
= НОД(А*В)*НОК(А, В). (по алгоритму Евклида на Паскале)Ответы на вопрос
Отвечает Schiffer Ulquiorra.
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
function NOD(a,b:integer):integer;
begin
while a <> b do
if a > b then a:=a-b
else b:=b-a;
NOD:=a
end;
begin
var a:=ReadInteger('A=');
var b:=ReadInteger('B=');
Writeln('HOK=',(a*b) div NOD(a,b))
end.
Тестовое решение:
A= 18
B= 42
HOK=126
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
