Вопрос задан 02.01.2019 в 15:38.
Предмет Информатика.
Спрашивает Бичагова Софья.
Написать программу определения стоимости разговора по телефону с учётом скидки 20%, предоставляемой
по субботам и воскресеньям. Входные данные: Sm(стоимость минуты разговора), M (число минут), Day (день недели - 1...7). Выходные данные: S (стоимость разговора). Ниже представлен вариант выполнения программы Вычисление стоимости телефонного разговора Введите исходные данные Стоимость минуты разговора, руб. 1 Длительность разговора (целое количество минут) 6 День недели (1-понедельник, ... 7-воскресенье) 7Ответы на вопрос
Отвечает Трач Алексей.
Var M, Day : integer; Sm, S : real;
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
write('Стоимость минуты разговора, руб. ');
readln(Sm);
write('Длительность разговора (целое количество минут) ');
readln(M);
write('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
then writeln('Стоимость разговора с учетом скидки = ',S*0.8)
else writeln('Стоимость разговора = ',S);
end.
Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 3.2
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора с учетом скидки = 15.36
begin
writeln('Вычисление стоимости телефонного разговора');
writeln('Введите исходные данные');
write('Стоимость минуты разговора, руб. ');
readln(Sm);
write('Длительность разговора (целое количество минут) ');
readln(M);
write('День недели (1-понедельник, ... 7-воскресенье) ');
readln(Day);
S:=Sm*M;
if (Day=6)or(Day=7)
then writeln('Стоимость разговора с учетом скидки = ',S*0.8)
else writeln('Стоимость разговора = ',S);
end.
Пример:
Вычисление стоимости телефонного разговора
Введите исходные данные
Стоимость минуты разговора, руб. 3.2
Длительность разговора (целое количество минут) 6
День недели (1-понедельник, ... 7-воскресенье) 7
Стоимость разговора с учетом скидки = 15.36
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
