Вопрос задан 01.01.2019 в 17:33.
Предмет Информатика.
Спрашивает Петренко Никита.
Напишите программу, которая на вход получает целое число и проверяет, есть ли в числе 2 одинаковые
цифры (pascal, с использованием циклов)Ответы на вопрос
Отвечает Юзыхович Егор.
Var a: array[0..9] of integer;
i,n,k: integer;
pr: string;
begin
pr:='нет';
for i:=0 to 9 do a[i]:=0;
write('число: '); readln(n);
repeat
k:=n mod 10;
a[k]:=a[k]+1;
if a[k]>1 then
begin
pr:='есть';
break;
end;
n:=n div 10;
until n=0;
writeln(pr);
end.
ввод - вывод
число: 122456
есть
число: 12546
нет
i,n,k: integer;
pr: string;
begin
pr:='нет';
for i:=0 to 9 do a[i]:=0;
write('число: '); readln(n);
repeat
k:=n mod 10;
a[k]:=a[k]+1;
if a[k]>1 then
begin
pr:='есть';
break;
end;
n:=n div 10;
until n=0;
writeln(pr);
end.
ввод - вывод
число: 122456
есть
число: 12546
нет
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
