Вопрос задан 01.01.2019 в 07:13.
Предмет Информатика.
Спрашивает Бездетко Алексей.
Задание: Составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран
элементов, значения которых являются квадратами целых чисел. Вот что я составил, но извлечение корня нельзя делать в integer:( Помогите! Program shist; Var a: array [1..10] of integer; i: integer; Begin writeln('ВВедите элементы массива:'); readln(i); writeln('Элементы массива, значения которых являются квадратами целых чисел:'); For i:=1 to 10 do if sqrt(i) then write (a[i], ' ') End.Ответы на вопрос
Отвечает Романенко Софья.
Текст программы на языке Паскаль:
program _1;
const N=10;
var i: integer;
a: array[1..N] of integer;
begin
for i:=1 to N do begin
readln(a[i]);
a[i]:=a[i]*a[i];
end;
for i:=1 to N do begin
writeln(a[i]);
end;
end.
program _1;
const N=10;
var i: integer;
a: array[1..N] of integer;
begin
for i:=1 to N do begin
readln(a[i]);
a[i]:=a[i]*a[i];
end;
for i:=1 to N do begin
writeln(a[i]);
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
