Вопрос задан 01.01.2019 в 01:31.
Предмет Информатика.
Спрашивает Бекбауова Улдана.
С++ Нужно написать программу которая бы распознавала наличие определённого символа в строке,
например точка, если да то вывести ответ да если нет-нет. Попробовал написать таким образом но оно не работает: #include using namespace std; int main(int argc, char** argv) { setlocale (LC_CTYPE, "Russian"); char string[5]; cout<<"vveidte stroku"; gets(string); if(string==".") cout<<"da"; else cout<<"no"; system("pause"); return 0; }Ответы на вопрос
Отвечает Баринова Ангелина.
#include <iostream>
using namespace std;
int main(int argc, char** argv)
{
setlocale (LC_CTYPE, "Russian");
string s;
int n=0;
cout<<"vveidte stroku\n";
getline (cin, s);
n = s.find(".");
if(n>=0)
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}
Пример:
vveidte stroku
если да то вывести ответ да если нет-нет.
da
using namespace std;
int main(int argc, char** argv)
{
setlocale (LC_CTYPE, "Russian");
string s;
int n=0;
cout<<"vveidte stroku\n";
getline (cin, s);
n = s.find(".");
if(n>=0)
cout<<"da";
else cout<<"no";
system("pause");
return 0;
}
Пример:
vveidte stroku
если да то вывести ответ да если нет-нет.
da
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
