Вопрос задан 29.12.2018 в 09:52.
Предмет Информатика.
Спрашивает Кузьмина Полина.
Напишите пожалуйста, как написать во FREE PASCAL число в степени i+1. Вот сама программа:Program
zadacha;Var k,s : Double; n,i : LongInt;Begin k:=0 ReadLn(n); s:=-1; For i:=1 to n do k:=k+exp((i+1)*Ln(s)); WriteLn(k:0:6); ReadLn;End.Вот условие задачи:Дано натуральное число n. Найдите сумму 1−1/2+1/3−...+(−1)n+1/n.Формат входных данных:Вводится целое число n(1≤n≤100000).Формат выходных данных:Требуется вывести одно число — значение выражения c точностью до шестого знака после запятой.Примечания:Условный оператор и оператор возведения в степень использовать запрещается.Ответы на вопрос
Отвечает Зобнин Игорь.
У вас программа считает не формулу, приведенную в условии.
Если делать по условию, то:
s := 0;
i := 1; while (i <= n) do begin s := s + 1/n; inc(n,2); end;
i := 2; while (i <= n) do begin s := s - 1/n; inc(n,2); end;
Если делать по условию, то:
s := 0;
i := 1; while (i <= n) do begin s := s + 1/n; inc(n,2); end;
i := 2; while (i <= n) do begin s := s - 1/n; inc(n,2); end;
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 10
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
