Вопрос задан 18.04.2018 в 23:50.
Предмет Информатика.
Спрашивает Михеева Аня.
Помогите написать программу в pascal. Найти разность наибольшей и наименьшей цифр 3-х значного
числа.Ответы на вопрос
Отвечает Хайлова Ксения.
Var a, b, c, r : integer;
begin
c:=0;
r:=9;
write('Введите число: ');
readln(a);
while a div 10 <> 0 do
begin
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
end;
b:=a mod 10;
a:=a div 10;
if b>c then c:=b;
if b<r then r:=b;
writeln('Разность: ', c-r);
end.
ДА ХОТЬ ДЛЯ 10 ЗНАЧНОГО))))
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
