Вопрос задан 27.12.2018 в 09:16.
Предмет Информатика.
Спрашивает Прутьян София.
На паскале У второклассников очень популярна следующая задача: 101=1 8181515=4 1111112=0 8888888=14
1010101=3 7000007=? Преподавателю программирования в некоем Центре для одаренных детей так понравилась эта задачка, что он решил именно ее использовать для проверки знаний математики 2-го класса у своих учеников. Пусть первое число x, а соответствующее ему n Входные данные Единственное неотрицательное число x, не превышающее 101001. Выходные данные Выведите n.Ответы на вопрос
Отвечает Князева Лиза.
{тоже как вариант}
const
v: array [0..9] of integer = (1,0,0,0,1,0,1,0,2,1);
var
x,n: integer;
begin
read(x);
n := 0;
repeat
n := n + v[x mod 10];
x := x div 10;
until x = 0;
write(n)
end.
const
v: array [0..9] of integer = (1,0,0,0,1,0,1,0,2,1);
var
x,n: integer;
begin
read(x);
n := 0;
repeat
n := n + v[x mod 10];
x := x div 10;
until x = 0;
write(n)
end.
Отвечает Круглов Кузьма.
Var
x: string;
n, i: integer;
begin
readln(x);
for i := 1 to length(x) do
case x[i] of
'0', '4', '6', '9': inc(n);
'8': inc(n, 2);
end;
writeln(n);
end.
x: string;
n, i: integer;
begin
readln(x);
for i := 1 to length(x) do
case x[i] of
'0', '4', '6', '9': inc(n);
'8': inc(n, 2);
end;
writeln(n);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
