Вопрос задан 27.12.2018 в 00:55.
Предмет Информатика.
Спрашивает Сухарева Настюша.
1.Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное
количиство граммов задается с клавиатуры.2.Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам. Длины сторон a,b и c задаются с клавиатуры.m1=...m2=...m3=...Ответы на вопрос
Отвечает Вопилова Кристина.
Const
x = 28.35;
var
g : Real;
begin
Write('Введите кол-во граммов: ');
ReadLn(g);
Writeln(g:0:3, ' грамм = ', g/x:0:3, ' унций.');
Readln;
end.
2:
var
a, b, c : Integer;
m : Real;
begin
Write('Введите сторону a: ');
ReadLn(a);
Write('Введите сторону b: ');
ReadLn(b);
Write('Введите сторону c: ');
ReadLn(c);
m := sqrt(2*sqr(b) + 2*sqr(c) - sqr(a))/2;
Writeln('Медиана к стороне a = ', m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(c) - sqr(b))/2;
Writeln('Медиана к стороне b = ', m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(b) - sqr(c))/2;
Writeln('Медиана к стороне с = ', m:0:3);
Readln;
end.

x = 28.35;
var
g : Real;
begin
Write('Введите кол-во граммов: ');
ReadLn(g);
Writeln(g:0:3, ' грамм = ', g/x:0:3, ' унций.');
Readln;
end.
2:
var
a, b, c : Integer;
m : Real;
begin
Write('Введите сторону a: ');
ReadLn(a);
Write('Введите сторону b: ');
ReadLn(b);
Write('Введите сторону c: ');
ReadLn(c);
m := sqrt(2*sqr(b) + 2*sqr(c) - sqr(a))/2;
Writeln('Медиана к стороне a = ', m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(c) - sqr(b))/2;
Writeln('Медиана к стороне b = ', m:0:3);
m := sqrt(2*sqr(a) + 2*sqr(b) - sqr(c))/2;
Writeln('Медиана к стороне с = ', m:0:3);
Readln;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
