Вопрос задан 14.12.2018 в 14:16.
Предмет Информатика.
Спрашивает Мединцев Максим.
Помогите с информатикой. Напишите программу, вычисляющую значение функции!!!

Ответы на вопрос
Отвечает Митрофанов Рома.
Var
x: real;
n: integer;
begin
Write('Введите любое число: ');Readln(x);
if x < 0 then n := -1
else
if x = 0 then n := 0 else n := 1;
Writeln('y=', n)
end.
Тестовое решение:
Введите любое число: 5
y=1
x: real;
n: integer;
begin
Write('Введите любое число: ');Readln(x);
if x < 0 then n := -1
else
if x = 0 then n := 0 else n := 1;
Writeln('y=', n)
end.
Тестовое решение:
Введите любое число: 5
y=1
Отвечает Трофимов Иван.
Var x, y: integer;
begin
write('Введите x: ');
readln(x);
if x < 0 then begin y := -1; writeln('y = ', y); end;
if x = 0 then begin y := 0; writeln('y = ', y); end;
if x > 0 then begin y := 1; writeln('y = ', y); end;
end.
begin
write('Введите x: ');
readln(x);
if x < 0 then begin y := -1; writeln('y = ', y); end;
if x = 0 then begin y := 0; writeln('y = ', y); end;
if x > 0 then begin y := 1; writeln('y = ', y); end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
